re = /([^\pL\pN\pS\pZ])|([\xC2\xA0])/
str = 'line_1
line_2'
subst = ' '
result = str.sub(re, subst)
# Print the result of the substitution
puts result