// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)([^\pL\pN\pS\pZ])|([\xC2\xA0])").unwrap();
let string = "line_1
line_2";
let substitution = " ";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}