const regex = /([^a-z0-9\n])/ug;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^a-z0-9\\n])', 'ug')
const str = `line_1
line_2`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);