import re
regex = re.compile(r"([^a-z0-9\n])", flags=re.UNICODE)
test_str = ("line_1\n"
"line_2")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)