$re = '/([^a-z0-9\n])/u';
$str = 'line_1
line_2';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;