use strict;
my $str = 'line_1
line_2';
my $regex = qr/([^a-z0-9\n])/up;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";