using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?im)^(?!$)(?:(Question|Problem:?|Example|[A-Z])[. ]?)?(\d+[. ]?)?(?=\s)";
string input = @"Q 12. This is question 1
Example 1 This is question 2 Q.1
Example This is question 3
EXAMPLE 2 This is question 4 2.3
Q.12. This is question 5
5.
Q 55.
Q 555
Q.555.
55555
Question 5555
Example
Problem 5555
Problem:
A5555.
EXAMPLE
Example 5555555";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}