import Foundation
let pattern = #"(?im)^(?!$)(?:(Question|Problem:?|Example|[A-Z])[. ]?)?(\d+[. ]?)?(?=\s)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Q 12. This is question 1
Example 1 This is question 2 Q.1
Example This is question 3
EXAMPLE 2 This is question 4 2.3
Q.12. This is question 5
5.
Q 55.
Q 555
Q.555.
55555
Question 5555
Example
Problem 5555
Problem:
A5555.
EXAMPLE
Example 5555555
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)