import re
regex = re.compile(r"(?im)^(?!$)(?:(Question|Problem:?|Example|[A-Z])[. ]?)?(\d+[. ]?)?(?=\s)", flags=re.MULTILINE)
test_str = ("Q 12. This is question 1\n"
"Example 1 This is question 2 Q.1\n"
"Example This is question 3\n"
"EXAMPLE 2 This is question 4 2.3\n"
"Q.12. This is question 5\n\n"
"5.\n"
"Q 55.\n"
"Q 555\n"
"Q.555.\n"
"55555\n"
"Question 5555\n"
"Example\n"
"Problem 5555\n"
"Problem:\n"
"A5555.\n"
"EXAMPLE\n"
"Example 5555555")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")