use strict;
my $str = 'Q 12. This is question 1
Example 1 This is question 2 Q.1
Example This is question 3
EXAMPLE 2 This is question 4 2.3
Q.12. This is question 5
5.
Q 55.
Q 555
Q.555.
55555
Question 5555
Example
Problem 5555
Problem:
A5555.
EXAMPLE
Example 5555555';
my $regex = qr/(?im)^(?!$)(?:(Question|Problem:?|Example|[A-Z])[. ]?)?(\d+[. ]?)?(?=\s)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}