#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?!\$RR(\d,?)+).)*$"
Local $sString = "$RR11470,1,7,2,0,2" & @CRLF & _
"Боліваріанський альянс для народів Нашої Америки був створений у:" & @CRLF & _
"1) 2002 р." & @CRLF & _
"2) 2003 р." & @CRLF & _
"3) 2004 р." & @CRLF & _
"4) 2005 р." & @CRLF & _
"" & @CRLF & _
"$RR11471,1,7,2,0,2" & @CRLF & _
"У межах АЛБА планується впровадження спільної валюти:" & @CRLF & _
"1) Болівар" & @CRLF & _
"2) Дінар" & @CRLF & _
"3) Ліра" & @CRLF & _
"4) Сукре" & @CRLF & _
"" & @CRLF & _
"$RR11473,1,7,2,0,2" & @CRLF & _
"Яка з перелічених країн не є учасником АЛБА:" & @CRLF & _
"1) Венесуела" & @CRLF & _
"2) Колумбія" & @CRLF & _
"3) Куба" & @CRLF & _
"4) Нікарагуа" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")