import Foundation
let pattern = #"^(?:(?!\$RR(\d,?)+).)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
$RR11470,1,7,2,0,2
Боліваріанський альянс для народів Нашої Америки був створений у:
1) 2002 р.
2) 2003 р.
3) 2004 р.
4) 2005 р.
$RR11471,1,7,2,0,2
У межах АЛБА планується впровадження спільної валюти:
1) Болівар
2) Дінар
3) Ліра
4) Сукре
$RR11473,1,7,2,0,2
Яка з перелічених країн не є учасником АЛБА:
1) Венесуела
2) Колумбія
3) Куба
4) Нікарагуа
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)