use strict;
my $str = '$RR11470,1,7,2,0,2
Боліваріанський альянс для народів Нашої Америки був створений у:
1) 2002 р.
2) 2003 р.
3) 2004 р.
4) 2005 р.
$RR11471,1,7,2,0,2
У межах АЛБА планується впровадження спільної валюти:
1) Болівар
2) Дінар
3) Ліра
4) Сукре
$RR11473,1,7,2,0,2
Яка з перелічених країн не є учасником АЛБА:
1) Венесуела
2) Колумбія
3) Куба
4) Нікарагуа
';
my $regex = qr/^(?:(?!\$RR(\d,?)+).)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}