re = /^(?:(?!\$RR(\d,?)+).)*$/m
str = '$RR11470,1,7,2,0,2
Боліваріанський альянс для народів Нашої Америки був створений у:
1) 2002 р.
2) 2003 р.
3) 2004 р.
4) 2005 р.
$RR11471,1,7,2,0,2
У межах АЛБА планується впровадження спільної валюти:
1) Болівар
2) Дінар
3) Ліра
4) Сукре
$RR11473,1,7,2,0,2
Яка з перелічених країн не є учасником АЛБА:
1) Венесуела
2) Колумбія
3) Куба
4) Нікарагуа
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end