#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[^\s@]*)[\w]{1}@{1}(?:[^\s@]+)[\.]{1}(?:[^\s@]{1,255}\w{1})$"
Local $sString = "good+alias@domain.com" & @CRLF & _
"good@sub.domain.com" & @CRLF & _
"good@domain.com" & @CRLF & _
"mail+alias@sub.domain.com" & @CRLF & _
"good.mail@domain.com" & @CRLF & _
"good.mail+alias@domain.com" & @CRLF & _
"wrong@mail.com." & @CRLF & _
"wrong.mail.@domain.com" & @CRLF & _
"wr.ong" & @CRLF & _
"wr@ong" & @CRLF & _
"wr@@ong.com" & @CRLF & _
"wr@o@n.g" & @CRLF & _
"wrong@mail.co@m" & @CRLF & _
"wrong+@domain.com" & @CRLF & _
"wro@.ng" & @CRLF & _
"wrong@." & @CRLF & _
"wron@g." & @CRLF & _
"wrong@" & @CRLF & _
"wrong"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")