# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[^\s@]*)[\w]{1}@{1}(?:[^\s@]+)[\.]{1}(?:[^\s@]{1,255}\w{1})$"
test_str = ("good+alias@domain.com\n"
"good@sub.domain.com\n"
"good@domain.com\n"
"mail+alias@sub.domain.com\n"
"good.mail@domain.com\n"
"good.mail+alias@domain.com\n"
"wrong@mail.com.\n"
"wrong.mail.@domain.com\n"
"wr.ong\n"
"wr@ong\n"
"wr@@ong.com\n"
"wr@o@n.g\n"
"wrong@mail.co@m\n"
"wrong+@domain.com\n"
"wro@.ng\n"
"wrong@.\n"
"wron@g.\n"
"wrong@\n"
"wrong")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.