re = /^(?:[^\s@]*)[\w]{1}@{1}(?:[^\s@]+)[\.]{1}(?:[^\s@]{1,255}\w{1})$/m
str = 'good+alias@domain.com
good@sub.domain.com
good@domain.com
mail+alias@sub.domain.com
good.mail@domain.com
good.mail+alias@domain.com
wrong@mail.com.
wrong.mail.@domain.com
wr.ong
wr@ong
wr@@ong.com
wr@o@n.g
wrong@mail.co@m
wrong+@domain.com
wro@.ng
wrong@.
wron@g.
wrong@
wrong'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end