use strict;
my $str = 'good+alias@domain.com
good@sub.domain.com
good@domain.com
mail+alias@sub.domain.com
good.mail@domain.com
good.mail+alias@domain.com
wrong@mail.com.
wrong.mail.@domain.com
wr.ong
wr@ong
wr@@ong.com
wr@o@n.g
wrong@mail.co@m
wrong+@domain.com
wro@.ng
wrong@.
wron@g.
wrong@
wrong';
my $regex = qr/^(?:[^\s@]*)[\w]{1}@{1}(?:[^\s@]+)[\.]{1}(?:[^\s@]{1,255}\w{1})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}