using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^\s@]*)[\w]{1}@{1}(?:[^\s@]+)[\.]{1}(?:[^\s@]{1,255}\w{1})$";
string input = @"good+alias@domain.com
good@sub.domain.com
good@domain.com
mail+alias@sub.domain.com
good.mail@domain.com
good.mail+alias@domain.com
wrong@mail.com.
wrong.mail.@domain.com
wr.ong
wr@ong
wr@@ong.com
wr@o@n.g
wrong@mail.co@m
wrong+@domain.com
wro@.ng
wrong@.
wron@g.
wrong@
wrong";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}