#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\[([^\]!]+)]\((https:\/\/[^\)]+)\)"
Local $sString = "# Title with Image [](https://other-example.com)" & @CRLF & _
"" & @CRLF & _
"## Links" & @CRLF & _
"" & @CRLF & _
"- [First link text](https://somesite.com/path/to-page) - voluptates explicabo debitis aspernatur dolor, qui dolores." & @CRLF & _
"- [Second one](https://example.io/this/is/page) - molestiae animi eius nisi quam quae quisquam beatae reiciendis." & @CRLF & _
"- [](https://example.io/other/page) aspernatur dolor, qui dolores adipisci deserunt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")