$re = '/\[([^\]!]+)]\((https:\/\/[^\)]+)\)/i';
$str = '# Title with Image [](https://other-example.com)
## Links
- [First link text](https://somesite.com/path/to-page) - voluptates explicabo debitis aspernatur dolor, qui dolores.
- [Second one](https://example.io/this/is/page) - molestiae animi eius nisi quam quae quisquam beatae reiciendis.
- [](https://example.io/other/page) aspernatur dolor, qui dolores adipisci deserunt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);