import re
regex = re.compile(r"\[([^\]!]+)]\((https:\/\/[^\)]+)\)", flags=re.IGNORECASE)
test_str = ("# Title with Image [](https://other-example.com)\n\n"
"## Links\n\n"
"- [First link text](https://somesite.com/path/to-page) - voluptates explicabo debitis aspernatur dolor, qui dolores.\n"
"- [Second one](https://example.io/this/is/page) - molestiae animi eius nisi quam quae quisquam beatae reiciendis.\n"
"- [](https://example.io/other/page) aspernatur dolor, qui dolores adipisci deserunt")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")