// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\[([^\]!]+)]\((https:\/\/[^\)]+)\)").unwrap();
let string = "# Title with Image [](https://other-example.com)
## Links
- [First link text](https://somesite.com/path/to-page) - voluptates explicabo debitis aspernatur dolor, qui dolores.
- [Second one](https://example.io/this/is/page) - molestiae animi eius nisi quam quae quisquam beatae reiciendis.
- [](https://example.io/other/page) aspernatur dolor, qui dolores adipisci deserunt";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}