using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[([^\]!]+)]\((https:\/\/[^\)]+)\)";
string input = @"# Title with Image [](https://other-example.com)
## Links
- [First link text](https://somesite.com/path/to-page) - voluptates explicabo debitis aspernatur dolor, qui dolores.
- [Second one](https://example.io/this/is/page) - molestiae animi eius nisi quam quae quisquam beatae reiciendis.
- [](https://example.io/other/page) aspernatur dolor, qui dolores adipisci deserunt";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}