import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/(\\w{2}|\\w{2}_\\w{2})/[^/]+/?$";
final String string = "https://domain/dir1/dir2/dir3/ag/lp\n"
+ "https://domain/dir1/dir2/dir2/dir4/en/lp/\n"
+ "https://domain/dir1/dir2/hi_en/lp\n"
+ "https://domain/dir1/dir2/cz/lp/\n"
+ "https://domain/dir1/dir2/dir3/dir4/lp";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}