use strict;
my $str = 'https://domain/dir1/dir2/dir3/ag/lp
https://domain/dir1/dir2/dir2/dir4/en/lp/
https://domain/dir1/dir2/hi_en/lp
https://domain/dir1/dir2/cz/lp/
https://domain/dir1/dir2/dir3/dir4/lp';
my $regex = qr//(\w{2}|\w{2}_\w{2})/[^/]+/?$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}