$re = '//(\w{2}|\w{2}_\w{2})/[^/]+/?$/';
$str = 'https://domain/dir1/dir2/dir3/ag/lp
https://domain/dir1/dir2/dir2/dir4/en/lp/
https://domain/dir1/dir2/hi_en/lp
https://domain/dir1/dir2/cz/lp/
https://domain/dir1/dir2/dir3/dir4/lp';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);