const regex = //(\w{2}|\w{2}_\w{2})/[^/]+/?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\/(\\w{2}|\\w{2}_\\w{2})\/[^\/]+\/?$', '')
const str = `https://domain/dir1/dir2/dir3/ag/lp
https://domain/dir1/dir2/dir2/dir4/en/lp/
https://domain/dir1/dir2/hi_en/lp
https://domain/dir1/dir2/cz/lp/
https://domain/dir1/dir2/dir3/dir4/lp`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}