import Foundation
let pattern = #"/(\w{2}|\w{2}_\w{2})/[^/]+/?$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
https://domain/dir1/dir2/dir3/ag/lp
https://domain/dir1/dir2/dir2/dir4/en/lp/
https://domain/dir1/dir2/hi_en/lp
https://domain/dir1/dir2/cz/lp/
https://domain/dir1/dir2/dir3/dir4/lp
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}