const regex = /((?<days>\d+)\sDays?\s?)?((?<hours>\d+)\sHours?\s?)?((?<minutes>\d+)\sMinutes?\s?)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?<days>\\d+)\\sDays?\\s?)?((?<hours>\\d+)\\sHours?\\s?)?((?<minutes>\\d+)\\sMinutes?\\s?)?', 'gm')
const str = `1 Hour
10 Hours 47 Minutes
1 Day 5 Hours 15 Minutes
45 Minutes
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}