re = /((?<days>\d+)\sDays?\s?)?((?<hours>\d+)\sHours?\s?)?((?<minutes>\d+)\sMinutes?\s?)?/m
str = '1 Hour
10 Hours 47 Minutes
1 Day 5 Hours 15 Minutes
45 Minutes
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end