$re = '/((?<days>\d+)\sDays?\s?)?((?<hours>\d+)\sHours?\s?)?((?<minutes>\d+)\sMinutes?\s?)?/m';
$str = '1 Hour
10 Hours 47 Minutes
1 Day 5 Hours 15 Minutes
45 Minutes
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);