import re
regex = re.compile(r"((?<days>\d+)\sDays?\s?)?((?<hours>\d+)\sHours?\s?)?((?<minutes>\d+)\sMinutes?\s?)?", flags=re.MULTILINE)
test_str = ("1 Hour\n"
"10 Hours 47 Minutes\n"
"1 Day 5 Hours 15 Minutes\n"
"45 Minutes\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")