# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\/\/TALKER=(?-s:(?!\/\/{scene_end}).+\R)+\K\R+//gm;t' <<< "//TALKER=Etna
Похоже, вы преуспеваете...
Вот небольшая награда.
Пожалуйста, возьмите её.
//{scene_end}"