import Foundation
let pattern = #"//TALKER=(?-s:(?!//{scene_end}).+\R)+\K\R+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
//TALKER=Etna
Похоже, вы преуспеваете...
Вот небольшая награда.
Пожалуйста, возьмите её.
//{scene_end}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)