$re = '~//TALKER=(?-s:(?!//{scene_end}).+\R)+\K\R+~m';
$str = '//TALKER=Etna
Похоже, вы преуспеваете...
Вот небольшая награда.
Пожалуйста, возьмите её.
//{scene_end}';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;