# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"//TALKER=(?-s:(?!//{scene_end}).+\R)+\K\R+"
test_str = ("//TALKER=Etna\n"
"Похоже, вы преуспеваете...\n"
"Вот небольшая награда.\n\n\n\n\n"
"Пожалуйста, возьмите её.\n"
"//{scene_end}")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.