const regex = new RegExp('//TALKER=(?-s:(?!//{scene_end}).+\\R)+\\K\\R+', 'gm')
const str = `//TALKER=Etna
Похоже, вы преуспеваете...
Вот небольшая награда.
Пожалуйста, возьмите её.
//{scene_end}`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);