#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sxX)#multi-line comment by Jeffrey Friedl (fastest)" & @CRLF & _
"/\*" & @CRLF & _
" [^*]* \*+" & @CRLF & _
" (?:[^*/][^*]*\*+)*" & @CRLF & _
"/" & @CRLF & _
"#multi-line comment by someone (slowest)" & @CRLF & _
"#/\* .*? \*/"
Local $sString = "" & @CRLF & _
"ghjgh hfj" & @CRLF & _
"fghfg hfg" & @CRLF & _
"" & @CRLF & _
"/*dfg fg ddf " & @CRLF & _
" dfdf* /hgf ghgfh " & @CRLF & _
"gd /*fg*/ dfg*/" & @CRLF & _
"" & @CRLF & _
"xcvsdgdf dfghdfg" & @CRLF & _
"" & @CRLF & _
"sdfsdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")