import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#multi-line comment by Jeffrey Friedl (fastest)\n"
+ "/\\*\n"
+ " [^*]* \\*+\n"
+ " (?:[^*/][^*]*\\*+)*\n"
+ "/\n"
+ "#multi-line comment by someone (slowest)\n"
+ "#/\\* .*? \\*/";
final String string = "\n"
+ "ghjgh hfj\n"
+ "fghfg hfg\n\n"
+ "/*dfg fg ddf \n"
+ " dfdf* /hgf ghgfh \n"
+ "gd /*fg*/ dfg*/\n\n"
+ "xcvsdgdf dfghdfg\n\n"
+ "sdfsdf";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}