using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#multi-line comment by Jeffrey Friedl (fastest)
/\*
[^*]* \*+
(?:[^*/][^*]*\*+)*
/
#multi-line comment by someone (slowest)
#/\* .*? \*/";
string input = @"
ghjgh hfj
fghfg hfg
/*dfg fg ddf
dfdf* /hgf ghgfh
gd /*fg*/ dfg*/
xcvsdgdf dfghdfg
sdfsdf";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}