re = /#multi-line comment by Jeffrey Friedl (fastest)
\/\*
[^*]* \*+
(?:[^*\/][^*]*\*+)*
\/
#multi-line comment by someone (slowest)
#\/\* .*? \*\//x
str = '
ghjgh hfj
fghfg hfg
/*dfg fg ddf
dfdf* /hgf ghgfh
gd /*fg*/ dfg*/
xcvsdgdf dfghdfg
sdfsdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end