// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sx)#multi-line comment by Jeffrey Friedl (fastest)
/\*
[^*]* \*+
(?:[^*/][^*]*\*+)*
/
#multi-line comment by someone (slowest)
#/\* .*? \*/").unwrap();
let string = "
ghjgh hfj
fghfg hfg
/*dfg fg ddf
dfdf* /hgf ghgfh
gd /*fg*/ dfg*/
xcvsdgdf dfghdfg
sdfsdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}