using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Billing Package for:(\w{3})\s-\sBL:(\w+)\s+TRANSID:(\d+)\s+-\s+(.+)";
string input = @"[EXTERNAL] Billing Package for:BOR - BL:N5227095 TRANSID:94331 - Darin Jones";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}