$re = '/Billing Package for:(\w{3})\s-\sBL:(\w+)\s+TRANSID:(\d+)\s+-\s+(.+)/m';
$str = '[EXTERNAL] Billing Package for:BOR - BL:N5227095 TRANSID:94331 - Darin Jones';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);