using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(?!.*\d)";
string input = @"0 Joseon Mun1JSM
1 Crazy pepe2CRAZYPEPE
2 NOOT (BRC-20)3NOOT
3 nomeme4NOMEME
4 Shrekt5HREK
5 WODIU6WODIU
6 Mr Bean Inu7MRBEAN
7 CMC DOGE8CMCDOGE
8 GEKE9GEKE
9 BLAZE TOKEN10BLZE
10 Toad Killer11$TOAD
11 LANDWOLF12LANDWOLF
12 Fonzy13FONZY
13 Iron Pepe14IPEPE
14 Bruv15BRUV";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}