import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(?!.*\\d)";
final String string = "0 Joseon Mun1JSM\n"
+ "1 Crazy pepe2CRAZYPEPE\n"
+ "2 NOOT (BRC-20)3NOOT\n"
+ "3 nomeme4NOMEME\n"
+ "4 Shrekt5HREK\n"
+ "5 WODIU6WODIU\n"
+ "6 Mr Bean Inu7MRBEAN\n"
+ "7 CMC DOGE8CMCDOGE\n"
+ "8 GEKE9GEKE\n"
+ "9 BLAZE TOKEN10BLZE\n"
+ "10 Toad Killer11$TOAD\n"
+ "11 LANDWOLF12LANDWOLF\n"
+ "12 Fonzy13FONZY\n"
+ "13 Iron Pepe14IPEPE\n"
+ "14 Bruv15BRUV";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}