import re
regex = re.compile(r"\d+(?!.*\d)", flags=re.MULTILINE)
test_str = ("0 Joseon Mun1JSM\n"
"1 Crazy pepe2CRAZYPEPE\n"
"2 NOOT (BRC-20)3NOOT\n"
"3 nomeme4NOMEME\n"
"4 Shrekt5HREK\n"
"5 WODIU6WODIU\n"
"6 Mr Bean Inu7MRBEAN\n"
"7 CMC DOGE8CMCDOGE\n"
"8 GEKE9GEKE\n"
"9 BLAZE TOKEN10BLZE\n"
"10 Toad Killer11$TOAD\n"
"11 LANDWOLF12LANDWOLF\n"
"12 Fonzy13FONZY\n"
"13 Iron Pepe14IPEPE\n"
"14 Bruv15BRUV")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")