use strict;
my $str = '0 Joseon Mun1JSM
1 Crazy pepe2CRAZYPEPE
2 NOOT (BRC-20)3NOOT
3 nomeme4NOMEME
4 Shrekt5HREK
5 WODIU6WODIU
6 Mr Bean Inu7MRBEAN
7 CMC DOGE8CMCDOGE
8 GEKE9GEKE
9 BLAZE TOKEN10BLZE
10 Toad Killer11$TOAD
11 LANDWOLF12LANDWOLF
12 Fonzy13FONZY
13 Iron Pepe14IPEPE
14 Bruv15BRUV';
my $regex = qr/\d+(?!.*\d)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}