import Foundation
let pattern = #"\d+(?!.*\d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0 Joseon Mun1JSM
1 Crazy pepe2CRAZYPEPE
2 NOOT (BRC-20)3NOOT
3 nomeme4NOMEME
4 Shrekt5HREK
5 WODIU6WODIU
6 Mr Bean Inu7MRBEAN
7 CMC DOGE8CMCDOGE
8 GEKE9GEKE
9 BLAZE TOKEN10BLZE
10 Toad Killer11$TOAD
11 LANDWOLF12LANDWOLF
12 Fonzy13FONZY
13 Iron Pepe14IPEPE
14 Bruv15BRUV
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)